Ide 컴파일버전 관련하여 질문드립니다

안녕하세요

기존 이더리움에서 ERC20으로 작업하다가 클레이튼으로 넘어온 개발자입니다.

클레이튼 IDE 로 작업을 하다가 IDE 버전이 업데이트 되었는지

컴파일 버전이 두개 밖에 없었는데 아래 처럼 버전이 추가된걸로 확인을 했습니다.

그리하여 기존에 ERC20 소스로 [0.6.2] 버전으로 그대로 가져와서 발행은 성공하였으나

ERC 기반에 토큰들은 KAS 별도로 토큰등록을 해야 토큰 History 조회가 가능하더라구요

그래서 등록을 할려고 했는데

컴파일버전이 0.4.24 , 0.5.6 두버전 밖에 없더라구요.

그래서 등록할 방법이 없어서 다른방법이 있을까 하여 질문 드립니다.

위에 작업은 Baobob 네트워크에서 진행하였습니다.

감사합니다.

안녕하세요,
KAS 제품팀입니다.

저희 KAS를 사용해주시어 감사합니다.
문의주신 내용에 대해서는 내부 확인 후 답변드릴 수 있도록 하겠습니다.

감사합니다.

KAS 제품팀 드림,

1 Like

안녕하세요
등록을 원하시는 토큰 주소를 알려주시면, scope을 통해 ERC20 여부를 판단하여 등록 도와드리겠습니다

1 Like

답변 감사드립니다.

테스트 토큰이기 때문에
번거롭게 지금추가하는것보다
나중에 라이브에 반영할때 요청드리도록하겠습니다.
아니면 KIP 로 새로 컨트랙트를 짜야 할것같습니다.
감사합니다.

2 Likes