최신 클레이튼 버전에 적합한 솔리디티 버전은 몇인가요?

안녕하세요 클레이튼 이제 막 공부를 시작한 사람입니다.~

클레이튼 공식문서에는 솔리디티 0.5 버전을 중심으로 작성된것 같네요?
솔리디티 0.8 버전이 최신인 것 같은데…
이런 버전들 때문에 참고하는 자료로 공부를하는 중 문제가 쫌 발생하는데…

혹시 추천하는 버전 조합이 있나요?
아니면 최신 버전 그대로 세팅해서 공부를 계속 하면 될까요?

@himmana

안녕하세요. 현재 Ethereum의 London 하드포크는 Baobab에만 적용이 되어 있는 상태입니다.
참고링크: 솔리디티 - 스마트 컨트랙트 언어 - Klaytn Docs KO

Solidity의 경우 Release Version 0.8.7 · ethereum/solidity · GitHub 부터 London 하드포크를 지원하고 있으므로 Klaytn의 Baobab 네트워크에서는 버전 문제 없이 사용이 가능하십니다.

다만 Cypress 네트워크에서는 아직까지 사용이 어려우므로 Cypress 에서는 0.5 버전대 사용을 권장드립니다.

더불어 아래 포럼 글도 참고해보시면 도움이 될 거 같습니다.

감사합니다.

2 Likes