Truffle을 통해 Baobab 네트워크에 스마트 컨트랙트 배포시 Migrations 단계에서 멈춤

truffle을 통해 kasBaobab 네트워크에 새로운 스마트 컨트랙트를 배포하였는데요. (KAS 사용 credential 및 account private key 사용)
기존에는 잘됐던 것이 현재 마이그레이션 단계에서 stuck이 되네요. kas console에 보면 Node API 사용량이 계속 올라가네요. github의 https://github.com/kjhman21/klaytn-contracts를 사용하였습니다.

  • 사용된 네트워크 truffle config
    kasBaobab: {
    provider: () => {
    const option = {
    headers: [
    { name: ‘Authorization’, value: 'Basic ’ + Buffer.from(accessKeyId + ‘:’ + secretAccessKey).toString(‘base64’) },
    { name: ‘x-chain-id’, value: ‘1001’ }
    ],
    keepAlive: false,
    }
    return new HDWalletProvider(privateKey, new Caver.providers.HttpProvider(“https://node-api.klaytnapi.com/v1/klaytn”, option))
    },
    network_id: ‘1001’, //Klaytn baobab testnet’s network id
    gas: ‘8500000’,
    gasPrice:‘25000000000’
    },

아래의 단계에서 멈춤 상태네요.

Starting migrations…

Network name: ‘kasBaobab’
Network id: 1001
Block gas limit: 0 (0x0)

1_initial_migration.js

Deploying ‘Migrations’

혹시, 위 문제 해결하셨나요? 저도 동일한 증상이 발생 되어서요…
원래 잘 동작 했었는데 이상하게 안되네요. ㅡㅡ;;;

@jm84.joo
@chwan

설정하신 GasPrice 값이 잘못된 거 같습니다.
25000000000 에서 30 곱한 값을 사용하시기 바랍니다.

참고: Gas Price Adjustment Announcement | by Klaytn | Klaytn | Feb, 2022 | Medium

1 Like

GasPrice 수정해서 정상동작 확인했습니다.
감사합니다 :slight_smile:

1 Like

Baobab 네트워크에 변경된 가스비 750 ston 적용된 것을 확인을 못했네요~ 저도 750 ston으로 변경하고 잘되는 것 확인했습니다. 답변 감사합니다!

1 Like

저도 동일한 문제인데 저는 가스비로 해결이 안되는군요…

gasPrice: null 로 하니 되는군요