Truffle-hdwallet-provider-klaytn 관련 문의

현재 환경의 node는 v10.15.3입니다.

npm install을 이용해 설치를 했으나 정상적으로 설치가 됐다고 판단할 방법이 있을까요??
여러대의 PC에서해봐도 동일합니다.

배포를 하려고하면 지속적으로
Error: Cannot find module 'truffle-hdwallet-provider-klaytn’
at Function.Module._resolveFilename (internal/modules/cjs/loader.js:582:15)
at Function.Module._load (internal/modules/cjs/loader.js:508:25)
at Module.require (internal/modules/cjs/loader.js:637:17)
at require (internal/modules/cjs/helpers.js:22:18)

의 에러가 발생하고 있어 진행이 힘드네요.

안녕하세요, 클레이튼 포럼에 질문을 올려주셔서 감사드립니다.

어떤 작업을 하시다가 해당 에러가 발생했는지 조금 더 설명해주실 수 있으실까요?

테스트넷에 배포를 해보려하는데 지속적으로 발생을 합니다.
node를 v12.19.0으로 업데이트를 해서 시도를 해도 동일하네요.

다만 truffle-hdwallet-provider-klaytn을 설치하는 과정에서 node-gyp rebuild, keccak, scrypt 같은 에러 메시지가 조금 있었습니다.

도움이 될지 모르겠습니다만
truffle을 이용해서 배포를 하시는 거라면
nvm을 이용해서 node version을 10.16.0으로 설정하고,
그 상태에서 truffle-hdwallet-provider-klaytn 설치한 후 해보시겠어요?

truffle-hdwallet-provider-klaytn을 설치할 때 node-gyp rebuild 부분에서 make 에러가 발생한 경우라면 build-essential을 설치하면 해결될 수도 있습니다.

sudo apt-get install build-essential

1 Like