Truffle을 이용한 컨트랙트 배포 중 에러

안녕하세요 바오밥 네트워크에 컨트랙트 배포 중 에러가 발생하여 문의 드립니다.
invalid unit price. 이구요 예전에도 가스비 인상 시에 이 에러가 발생했었는데, 가스비를 얼마로 올리면 될까요?

다음은 현재 truffle-config.js 파일 입니다.

module.exports = {
networks: {
ganache: {
host: “127.0.0.1”,
port: 8545,
network_id: “*”,
},
baobab: {
provider: new HDWalletProvdider(PRIVATE_KEY_TEST, TEST_URL),
network_id: 1001,
gas: 20000000,
gasPrice: 25000000000 * 30
},

안녕하세요! 담당자는 아니지만 댓글 남깁니다.

baobab: {
      provider: () => new HDWalletProvider(BAOBAB_PRIVATE_KEY, BAOBAB_URL),
      network_id: BAOBAB_NETWORK_ID, //const BAOBAB_NETWORK_ID = "1001";
      gas: GASLIMIT, //const GASLIMIT = "8500000";
      gasPrice: null,
    },

이렇게 진행하는데 에러없이 잘 배포되고있습니다!
메인넷도 마찬가지이구요!

가스비 수정이 있었네요

baobab: 250000000000 (5/12 부터)

(cypress 5/22 부터 적용 예정)

결론
gasPrice: 250000000000
로 수정후 배포

1 Like