Npm caver-js 설치후 사용시 모듈 에러

안녕하세요.
클레이튼 컨트렉트를 연동중에 caver-js를 설치까지는 잘되나, 사용하려고 하면
This dependency was not found: friendly-errors 18:31:12
friendly-errors 18:31:12

  • fs in ./node_modules/caver-js/packages/caver-ipfs/src/index.js friendly-errors 18:31:12
    friendly-errors 18:31:12
    To install it, you can run: npm install --save fs

해당 에러가 발생하고있습니다.

fs 는 메시지에 나와있는것처럼 설치도 해보고 전역으로도 설치해보앗지만
전혀 해결이 안되고있습니다.

caver-js 를 require 하는것만으로도 오류가 나고있는 상태입니다.
제가 무슨 잘못을했을지요 ㅠㅜ
caver-js는 1.8.0 버전입니다.

사용하시는 NPM 버젼도 같이 공유해주실 수 있으신가요?

2 Likes

npm 버전은 8.1.0 입니다.

node 최신버전 사용중입니다.